OpenConcerto 1.4.2

Avatar du membre
guillaume
Messages : 2278
Enregistré le : ven. févr. 11, 2011 7:15 pm

jeu. oct. 13, 2016 3:40 pm

Bonjour seb,

Vos logs indiquent :

Code : Tout sélectionner

File corrupted while reading record
Cela signifie que votre fichier de base de données est abîmé, les causes possibles sont nombreuses :
- virus
- antivirus
- mémoire vive défectueuse
- disque dur défectueux
- arrêt du PC quand OpenConcerto est encore lancé

Il n'y a que 2 possibilités :
- restaurer le fichier depuis une sauvegarde
ou
- faire appel à la hotline pour réparer le fichier de base de données

Cordialement,
Directeur technique d'OpenConcerto qui dans son temps libre s'occupe du forum.
Pour une assistance pro, nous sommes joignables à ILM Informatique contre quelques jetons.
Pensez aussi à lire le manuel !
ellinggton
Messages : 16
Enregistré le : mar. nov. 25, 2014 12:14 pm

mar. oct. 25, 2016 9:45 pm

Bonjour.

Merci pour la mise à jour.

sur une version 1.4.1 installée sur un win 10 (une tablette tactile intel pentium) la cloture de la caisse prenait jusqu'à 25 min voire 40 min. est-ce un souci récurrent ? est-ce corrigé sur cette version ? cdlt.
Avatar du membre
guillaume
Messages : 2278
Enregistré le : ven. févr. 11, 2011 7:15 pm

mer. oct. 26, 2016 1:43 pm

Bonjour,

Version monoposte ou multiposte?
Dans le 2eme cas, problème réseau ou serveur.


Cordialement,
Directeur technique d'OpenConcerto qui dans son temps libre s'occupe du forum.
Pour une assistance pro, nous sommes joignables à ILM Informatique contre quelques jetons.
Pensez aussi à lire le manuel !
palijn
Messages : 4
Enregistré le : mar. nov. 17, 2015 11:42 am

jeu. nov. 10, 2016 7:08 pm

Bonjour,
Je tente une installation multiposte de OC 1.4.2 sur une BD toute neuve. Téléchargements tout neufs aussi!

Lors de l'exécution de

Code : Tout sélectionner

psql OpenConcerto < OpenConcerto-1.4.2.sql
, j'ai une flopée d'erreurs concernant un mystérieux default_tablespace "RAID" :
ERROR: invalid value for parameter "default_tablespace": "RAID"
DETAIL: Tablespace "RAID" does not exist.
Il me semble avoir déjà lu ça pour OC 1.3 ... est-ce que ces valeurs doivent simplement être remises à

Code : Tout sélectionner

default_tablespace=''
dans le SQL ?

Merci!
Samuel_Burg
Messages : 144
Enregistré le : mer. juil. 22, 2015 12:17 pm

lun. nov. 14, 2016 9:02 am

Bonjour,

à tout les coups vous avez pas initialiser les droit adéquats sur le serveur postgrsql :

Code : Tout sélectionner

psql -c "CREATE USER openconcerto"
psql -c "ALTER USER openconcerto WITH PASSWORD 'openconcerto'"
psql -c "ALTER ROLE openconcerto WITH CREATEDB"
psql -c "CREATE DATABASE \"OpenConcerto\" OWNER openconcerto"
psql -c "GRANT ALL PRIVILEGES ON DATABASE \"OpenConcerto\" to openconcerto"

psql OpenConcerto < C:\OpenConcerto-1.4.sql
Cordialement,
Samuel_Burg
Messages : 144
Enregistré le : mer. juil. 22, 2015 12:17 pm

lun. nov. 14, 2016 9:05 am

ah,
encore un petit truc,

les scripts sql fournis pour les différentes versions 1.3 et 1.4 sont parfaitement justes,
donc si le script plante, c'est que vous avez fait une erreur quelque part, il ne faut pas modifier le script lui même.

Cordialement,
cedric.maupas
Messages : 42
Enregistré le : mer. mars 14, 2012 8:33 am
Contact :

jeu. déc. 08, 2016 9:23 am

Cette ligne est propre à la configuration de ILM selon le post suivant
Re: OpenConcerto 1.3 disponible
Messagede guillaume » Mar Mar 11, 2014 5:18 pm
Version OC 1.6.2 multiposte / Postgresql 9.5 / Windows serveur 2012
Utilisateur OC depuis janvier 2012
tahitibub
Messages : 23
Enregistré le : sam. mars 26, 2011 12:51 am

sam. déc. 24, 2016 4:49 am

Bonjour,

A l'instar de palijn (voir 4 messages ci-dessus), je rencontre moi aussi les erreurs liées à Tablespace "RAID" does not exist, sur une installation toute fraîche réalisée sur la base de la dernière version BigSQL (PostgreSQL9.6.1-1-win64-bigsql).

J'ai acheté le manuel OpenConcerto, mais il n'est pas assez clair, et n'est plus adapté aux versions actuelles de PostgreSQL et PgAdmin :

- il décrit l'utilisation d'une ancienne version de PgAdmin (pages 105-106) ;
- il est silencieux quant aux droits à donner à l'utilisateur openconcerto (page 106) ;
- le lancement du "SQL shell (psql)" ne donne pas ce qui est indiqué page 107. En particulier, il ne demande pas les infos de connexion comme indiqué sur la copie écran.

Aussi, j'utilise la méthode de création de l'utilisateur "openconcerto" et de la base "OpenConcerto" en lignes de commandes préconisée 3 messages plus haut, en ayant pris le soin d'ajouter le paramètre "-U". Voici ce que cela donne en invite de commandes Windows :

Code : Tout sélectionner

psql -U postgres -c "CREATE USER openconcerto"
CREATE ROLE

psql -U postgres -c "ALTER USER openconcerto WITH PASSWORD 'openconcerto'"
ALTER ROLE

psql -U postgres -c "ALTER ROLE openconcerto WITH CREATEDB"
ALTER ROLE

psql -U postgres -c "CREATE DATABASE \"OpenConcerto\" OWNER openconcerto"
CREATE DATABASE

psql -U postgres -c "GRANT ALL PRIVILEGES ON DATABASE \"OpenConcerto\" to openconcerto"
GRANT
Néanmoins, comme annoncé supra, j'obtiens moi aussi ce genre d'erreurs au lancement du script (psql -U openconcerto OpenConcerto < C:\OpenConcerto-1.4.2.sql) :

ERROR: language "plpgsql" already exists
ERROR: must be owner of language plpgsql
SET
ERROR: permission denied for language c
ERROR: function Common.plpgsql_call_handler() does not exist
ERROR: permission denied for language c
ERROR: function Common.plpgsql_validator(oid) does not exist
ERROR: invalid value for parameter "default_tablespace": "RAID"
DÉTAIL : Tablespace "RAID" does not exist
.

Questions :

- Comment faire pour lancer ce script sans erreurs sous Windows 10 et PostgreSQL-9.6.1-1-win64-bigsql ?

- Ce script "OpenConcerto-1.4.2.sql" est il aussi valable pour la nouvelle beta 1.5 ?

- Enfin, peut-on utiliser MariaDB au lieu de PostgreSQL ?

Merci de votre aide.

Cordialement,
Avatar du membre
guillaume
Messages : 2278
Enregistré le : ven. févr. 11, 2011 7:15 pm

sam. déc. 24, 2016 11:13 am

Bonjour,

Installer une base de données c'est rapide mais la maîtriser ça demande de lire la doc, voici quelques infos pour vous permettre d'aller plus loin, mais que ca ne vous dispense pas de lire les docs de PostgreSQL.

Si vous avez Tablespace "RAID" does not exist, vous pouvez supprimer les lignes :

Code : Tout sélectionner

SET default_tablespace = "RAID";
ou créer créer cet espace sur un système Raid par exemple (c'est fortement conseillé).

Dans le manuel, nous utilisons PostgreSQL 9.1 et pgAdmin 3 (éviter la version 4, elle est extrêmement buggée).
OpenConcerto est compatible avec toutes les versions 9.x.

Le plus simple est de toujours utiliser les commandes dans un terminal (Invite de commandes sur windows).

Quand vous utilisez

Code : Tout sélectionner

psql -U postgres -c "GRANT ALL PRIVILEGES ON DATABASE \"OpenConcerto\" to openconcerto"
, l'utilisateur a tous les privilèges.
Dans les faits, si vous voulez restreindre, le logiciel a besoin (en plus d'accéder aux données) de pouvoir modifier et créer des tables et des schémas.

Pour la 1.5b1, il suffit d'installer la 1.4.2 et de mettre à jour avec l'outil de configuration. Nous fournirons les .sql en version 1.5 finale.

Pour ce qui est de MySQL/MariaDB, oui c'est possible, mais nous ne fournissons pas de .sql clef en main, c'est donc réservé aux experts qui aiment utiliser cette base. PostgreSQL est un bien meilleur choix technique.

Cordialement,
Directeur technique d'OpenConcerto qui dans son temps libre s'occupe du forum.
Pour une assistance pro, nous sommes joignables à ILM Informatique contre quelques jetons.
Pensez aussi à lire le manuel !
occalp
Messages : 30
Enregistré le : mer. juil. 06, 2016 11:41 am

sam. déc. 24, 2016 12:38 pm

Bonjour,

Pour info une installation de la V1.4.2 sur PostGreSQL 9.6.0 beta windows fonctionne très bien.

Bien cordialement,
Répondre