mise à jour vers 1.6 depuis 1.3 possible ?

Un conseil pour l'installation? Un problème technique pour installer OpenConcerto?
Répondre
jardinenvie
Messages : 1
Enregistré le : mer. janv. 16, 2013 2:39 pm

mar. janv. 01, 2019 11:10 pm

Bonjour,

Jusqu'ici nous utilisions une version 1.3 de OpenConcerto avec postgresql, sans souci particulier.

A l'occasion de changer de serveur, j'ai voulu passer à la version 1.6 de OpenConcerto.

La lecture de divers messages du forum m'a laissé penser qu'il était possible de faire des mises à niveau de la base en sautant des versions.

Tout se passe bien jusqu'à la mise à niveau. J'accède à nos données via les commandes en ligne. Mais impossible de faire la mise à niveau. Message d'erreur : Missing table exception.

Quelqu'un aurait-il déjà rencontré ce problème ? Peut-être le saut est-il trop grand ?

J'arrive à faire fonctionner une version 1.6 avec la table d'exemple. Elle est accessible et fonctionnelle de tous les postes de notre réseau local.

Je nettoie la base OpenConcerto pour tenter une nouvelle injections de notre sauvegarde (avec pg-restore suite à pg_dump). Tout se passe bien. Mais toujours impossible de migrer la base.

Faut-il faire des mises à jour successives de la base en installant les 10 versions qui séparent la 1.3 de la 1.6 ?

Car passer de la 1.3 à la 1.3.1 se fait bien. Il n'y a peut-être pas de grandes différences de structure de base entre ces versions proches...

Avant de nous lancer, si quelqu'un a une idée pour éviter cela, merci d'avance !
SRI
Messages : 88
Enregistré le : mer. mars 15, 2017 8:50 pm

mer. janv. 02, 2019 1:51 pm

Je pense qu'il n'est pas possible de passer directement de la 1.3 à la 1.6 sans passer par les versions intermédiaires.
J'ai déjà eu de petits problèmes lorsque j'avais loupé des versions intermédiaires. J'avais fait alors appel à l'assistance.
Utilisateur Cloud et maintenance Premium.
Répondre